Requirements

From refbase

Installation of the refbase package requires:

  • the refbase scripts (official release or latest development version from SVN)
  • a web server (like the Apache HTTP Server)
  • PHP (version 4.4.0 or greater) with enabled session support & installed PHP MySQL module and PCRE (version 6.5 or greater); PHP >=5.2 is strongly encouraged
  • MySQL (version 4.1.x or greater required for Unicode support)
    • the Apache Friends project offers a complete solution for above mentioned services (Apache, PHP, MySQL), called XAMPP; the easy-to-use package is available for different platforms (Linux, Windows, Mac OS X, Solaris).
  • optionally, Bibutils for import and export of various formats (e.g., Endnote & BibTeX)

In addition, there are some required php.ini settings.

refbase-0.9.0 or greater has these further requirements:

  • the features that allow for automatic renaming of uploaded files require the iconv functions, i.e. PHP must have been compiled with the --with-iconv configure-option
  • Unicode (UTF-8) support requires the multibyte string functions being enabled on your PHP server, i.e., PHP must have been compiled with the --enable-mbstring configure option; however, refbase can be used with a latin1 (ISO-8859-1) database if multibyte support is not available on your server